units metal vs real -Reaxff

Hi lammps-users,

I have been calculating with reax force field some gold systems, I have always used units real.

By error I did a calculation of the lattice with units metal, I was wondering why the output of the potential energy for both runs (with real and metal units) are the same. For real units energy should be printed in kcal/mol and for metal in eV, or with reax the default is real units (I think not)?

Probably I am making a very dummy mistake!

I attach the *in file!

thanks for the help!

lammps version: Stable version (11 Aug 2017)

calc_fcc.in (1.14 KB)

Hi lammps-users,

I have been calculating with reax force field some gold systems, I have
always used units real.

By error I did a calculation of the lattice with units metal, I was
wondering why the output of the potential energy for both runs (with real
and metal units) are the same. For real units energy should be printed in
kcal/mol and for metal in eV, or with reax the default is real units (I
think not)?

i think yes. the reaxff force field parameter files contain parameters
in real units.
so if you set units to metal in your input, they will be interpreted
as if they were in metal units instead, which may lead to all kinds of
funny behavior and outputs unless you convert the entries in the
parameter file to be in metal units as well (which is horribly tedious
to get done correctly)

axel.

Hi Alexandra,

as a little addition to Axel’s answer, I’d like to note that the force field itself is a function that transforms numbers into numbers (atomic coordinates to forces and energies). As atomic coordinates are the same in both real and metal units, the force field produces the same numbers. Errors appear when these numbers are interpreted (by a human, when one thinks the energies in the output are in eV, or by other parts of code, as in calculation of pressure). ReaxFF parameters are trained so that the numbers it gives are realistic in real units.

Oleg

18.10.2017, 17:06, “Alexandra Davila” <[email protected]…6924…>: