Updated EMC v9.4.4 including VMD plugin

2021/08/20: I uploaded a new version v9.4.4 to http://montecarlo.sourceforge.net/ which includes a corrected EMC GUI plugin for VMD. Check out ./vmd/README on how to include this GUI with your VMD.

Thank you for your contribution.
However, I failed to add the GUI plugin to VMD these days following everything described in the README file. Every time I initiated VMD, the error line ‘can’t find package Thread’ popped out.
I have installed the TCL extension ‘thread 2.8.5’, and ‘tclsh’ actually can find the pacakge Thread.
I just don’t understand why VMD can’t locate it during initiation.
I have tried to add auto_path before the line ‘package require Thread’ in the file ‘gui.tcl’.
I have also tried to create a pkgIndex.tcl file.
I think maybe it’s better to put the packages directly into the dir of VMD according to the ’ Writing Tcl/Tk plugins and extensions for VMD’ (https://www.ks.uiuc.edu/Research/vmd/plugins/doxygen/tcltkplugins.html).


Thank you for your report. I am sorry to hear you don’t seem to be able to get the plugin to work. I seem to recall, that VMD comes with its own Tcl, which means, that adding a package to your system Tcl might not work. Which operating system are you trying to add the plugin for?


Update: I noticed, that VMD v1.9.4 uses a different Tcl version, which conflicts with the solution I chose for following EMC’s progress during building in VMD. The GUI was designed to work with VMD v1.9.3. I will fix the conflict and upload an update on Dec 1, 2021 at the latest.