ValueError: bandgap option set but system is metallic

Dear Alex and kind users,
When I use amset to calculate mobility, after typing: “bash main.py”, I got the amset.log like this:

     /$$$$$$  /$$      /$$  /$$$$$$  /$$$$$$$$ /$$$$$$$$
    /$$__  $$| $$$    /$$$ /$$__  $$| $$_____/|__  $$__/
   | $$  \ $$| $$$$  /$$$$| $$  \__/| $$         | $$
   | $$$$$$$$| $$ $$/$$ $$|  $$$$$$ | $$$$$      | $$
   | $$__  $$| $$  $$$| $$ \____  $$| $$__/      | $$
   | $$  | $$| $$\  $ | $$ /$$  \ $$| $$         | $$
   | $$  | $$| $$ \/  | $$|  $$$$$$/| $$$$$$$$   | $$
   |__/  |__/|__/     |__/ \______/ |________/   |__/

                                                v0.4.15

  Ganose, A. M., Park, J., Faghaninia, A., Woods-Robinson,
  R., Persson, K. A., Jain, A. Efficient calculation of
  carrier scattering rates from first principles.
  Nat. Commun. 12, 2222 (2021)

amset starting on 09 Apr 2022 at 20:06


Run parameters:
  - scattering_type: auto
  - doping: [-1.e+14 -1.e+15 -1.e+16 -1.e+17 -1.e+18]
  - temperatures: [300]
  - bandgap: 4.9
  - soc: False
  - zero_weighted_kpoints: prefer
  - interpolation_factor: 80
  - wavefunction_coefficients: wavefunction.h5
  - use_projections: False
  - free_carrier_screening: False
  - high_frequency_dielectric: 
      [[  3.93   0.00  -0.00]
       [  0.00   4.04   0.00]
       [ -0.00   0.00   4.03]]
  - static_dielectric: 
      [[ 10.88   0.00  -1.34]
       [  0.00  10.23   0.00]
       [ -1.34   0.00  14.28]]
  - elastic_constant: 
      [[ 241.9  128.2  142.2    0.0  -16.7    0.0]
       [ 128.2  344.1   89.8    0.0   11.5    0.0]
       [ 142.2   89.8  340.2    0.0    8.4    0.0]
       [   0.0    0.0    0.0   53.6    0.0   20.1]
       [ -16.7   11.5    8.4    0.0   64.2    0.0]
       [   0.0    0.0    0.0   20.1    0.0   92.3]]
  - deformation_potential: deformation.h5
  - defect_charge: 1
  - compensation_factor: 2
  - pop_frequency: 12.56
  - energy_cutoff: 1.5
  - fd_tol: 0.05
  - dos_estep: 0.01
  - symprec: 0.01
  - nworkers: -1
  - cache_wavefunction: True
  - calculate_mobility: True
  - separate_mobility: True
  - mobility_rates_only: False
  - file_format: json
  - write_input: False
  - write_mesh: True
  - print_log: True
  - write_log: True


~~~~~~~~~~~~~~~~~~~~~~~~~~~~ STRUCTURE ~~~~~~~~~~~~~~~~~~~~~~~~~~~~

Structure information:
  - formula: Ga3O2
  - # sites: 20
  - space group: C2/m

Lattice:
  - a, b, c [angstrom]: 12.23, 3.04, 5.80
  - a, b, y [deg]: 90, 104, 90


~~~~~~~~~~~~~~~~~~~~~~~~~~ BAND STRUCTURE ~~~~~~~~~~~~~~~~~~~~~~~~~

Input band structure information:
  - # bands: 144
  - # k-points: 36
  - Fermi level: 9.855 eV
  - spin polarized: False
  - metallic: True


~~~~~~~~~~~~~~~~~~~~~~~~~~ INTERPOLATION ~~~~~~~~~~~~~~~~~~~~~~~~~~

Getting band interpolation coefficients
  - time: 0.7441 s


  ERROR: amset exiting on 09 Apr 2022 at 20:06
Traceback (most recent call last):
  File "main.py", line 51, in <module>
    amset_data = runner.run()
  File "/home/chen/mph/InstallPackage/Application/Anaconda/envs/py3
7/lib/python3.7/site-packages/amset/core/run.py", line 68, in run
    multiprocess=True,
  File "/home/chen/mph/InstallPackage/Application/Anaconda/envs/py3
7/lib/python3.7/site-packages/memory_profiler.py", line 336, in 
memory_usage
    returned = f(*args, **kw)
  File "/home/chen/mph/InstallPackage/Application/Anaconda/envs/py3
7/lib/python3.7/site-packages/amset/core/run.py", line 111, in 
_run_wrapper
    amset_data, interpolation_time = self._do_interpolation()
  File "/home/chen/mph/InstallPackage/Application/Anaconda/envs/py3
7/lib/python3.7/site-packages/amset/core/run.py", line 207, in 
_do_interpolation
    nworkers=self.settings["nworkers"],
  File "/home/chen/mph/InstallPackage/Application/Anaconda/envs/py3
7/lib/python3.7/site-
packages/amset/interpolation/bandstructure.py", line 178, in 
get_amset_data
    "bandgap" if bandgap else "scissor"
ValueError: bandgap option set but system is metallic


But Ga2O3 is semiconductors not Metal,How can I solve this problem?

You should double check your VASP calculation. Sometimes with tetrahedron smearing (ISMEAR = -5), VASP puts the Fermi level just inside on the conduction or valence bands. You can fix it by modifying the Fermi level in vasprun.xml.

Dear Alex,

You are very generous and kind! Thank you very much!

Best wishes,
Chenjiashu