VMD openGL does not work with Xforwarding

Greetings,

I am trying to use Xforwarding to open vmd remotely and visualize lammps trajectories. My local machine is Mac but the remote one on the su[ercomputer is a linux. I can successfully open VMD using Xforwarding, yet the OpenGL display does not show anything even after I import the molecular data. Has anyone ran into issues like this before?

1 Like

Even if this only happens with lammps trajectories, it’s a VMD issue, and you should ask their mailing list.

3 Likes

I have faced similar problems while forwarding display from clusters. When the VMD viewport opens, does it show the initial revolving logo? In my case the window used to open but without any logo. Everything worked properly when I ssh using MobaXterm from Windows. From linux, using “xhost +” before ssh also solved the problem, but not always. If you find a permanent solution, do share it.

As already mentioned by @Michael_Jacobs this is a topic for a discussion on the VMD mailing list, but not here. There is a lengthy explanation and some rather complex workarounds for this, but this is not the proper place to discuss this.

Please let me also note that using “xhost +” is a very, very bad idea. It turns off all access protection on your Xserver and thus potentially allows anybody from anywhere to monitor what is going on (unless you have protection from a properly configured firewall). One can literally “see” everything you do and log every keystroke and mouseclick without you getting to know anything about it or even remote control your machine.

2 Likes