world variable & number of partitions

Dear LAMMPS users ,

I want to do replica exchange simulation .

So I use : variable t world 300.0 310.0 320.0 330.0

​and ​
temper 100000 100 $t
​ ​FIXV
​ ​
3847​ ​
58382​ ​
commands .

When I want to run the input file by this command :
​mpirun -np 4 lmp_mpi -p 4*1 -in in.Layer

​I get error ​: ERROR: World variable count doesn’t match # of partitions (…/variable.cpp:225)

​Number of values are equal to the number of processor partitions but I don’t know why i get this error ?
Can you please help me about that ?

Regards,
Saeed.​

Dear LAMMPS users ,

I want to do replica exchange simulation .

So I use : variable t world 300.0 310.0 320.0 330.0
and
temper 100000 100 $t
FIXV

3847
58382

commands .

When I want to run the input file by this command :
mpirun -np 4 lmp_mpi -p 4*1 -in in.Layer

I get error : ERROR: World variable count doesn't match # of partitions
(../variable.cpp:225)

Number of values are equal to the number of processor partitions but I don't
know why i get this error ?

your syntax for specifying partitions is wrong.

http://lammps.sandia.gov/doc/Section_start.html#command-line-options

axel.

Dear Axel ,

I read the link before sending this Email at the first time .
Can you please help me figure out what is wrong with my command ?

Regards,
Saeed.

It’s not 4*1, its 4x1.

Steve

​​Dear Steve ,

Thanks for your reply .
There is no difference between 4*1 and 4x1 .
When I use : mpirun -np 4 lmp_mpi -p 4×1 -in in.input
for input file that I mentioned below I get this error : World variable count doesn’t match # of partitions (…/variable.cpp:225)
Can you please let me know what the problem is ?
I use lammps-30Jul16 .

This is my input file :

variable t world 300 310 320 330

units real
dimension 3
boundary p p p
atom_style full
bond_style harmonic
angle_style harmonic
pair_style lj/cut/tip4p/cut 2 1 1 1 0.1546 12.0 8.5

Dear Steve ,

Thanks for your reply .
There is no difference between 4*1 and 4x1 .
When I use : mpirun -np 4 lmp_mpi -p 4×1 -in in.input
for input file that I mentioned below I get this error : World variable
count doesn't match # of partitions (../variable.cpp:225)
Can you please let me know what the problem is ?

works for me:

[[email protected]... Downloads]$ mpirun -np 4 lmp_mpi -p 4x1 -in in.input
LAMMPS (27 Oct 2016)
Running on 4 partitions of processors
Setting up tempering ...
Step T0 T1 T2 T3
0 0 1 2 3
100 1 0 2 3
200 1 0 2 3
300 2 0 1 3
[...]

axel.

Dear Axel ,

I really don’t understand what the problem is in my own PC !
By this command : mpirun -np 4 lmp_mpi -p 4x1 -in in.input

I get this error in log.lammps.0 file : ERROR: World variable count doesn’t match # of partitions (…/variable.cpp:225)

and this error from mpi :

Dear Axel ,

I really don't understand what the problem is in my own PC !
By this command : mpirun -np 4 lmp_mpi -p 4x1 -in in.input

I get this error in log.lammps.0 file : ERROR: World variable count doesn't
match # of partitions (../variable.cpp:225)

and this error from mpi :

*************************************************************************************************

LAMMPS (30 Jul 2016)
Running on 1 partitions of processors

this indicates, that you are not providing a correctly formatted argument to -p.
possibly it has some non-ascii characters or something else is wrong.
you can try switch to a C locale and turning of native language
support. LAMMPS is written with the assumption that all strings (in
input files and arguments) are valid 7-bit ASCII characters.

you could try using -p 1 1 1 1 instead of -p 4x1. these are equivalent.

at the moment, the code doing the parsing of the arguments to the
partition flag assumes, that the user provides correct input.
i have just submitted some changes for inclusion into the next patch
release for LAMMPS, that checks more carefully.

https://github.com/lammps/lammps/pull/248/commits/7d23a0737ef5a51d53ff92578c0ddcd3c568ea96

-------------------------------------------------------
Primary job terminated normally, but 1 process returned
a non-zero exit code.. Per user-direction, the job has been aborted.
-------------------------------------------------------
--------------------------------------------------------------------------
mpirun detected that one or more processes exited with non-zero status, thus
causing
the job to be terminated. The first process to do so was:

  Process name: [[3257,1],1]
  Exit code: 1

******************************************************************************************************

Do you have any idea about that ?

no. the error is definitely on your side and your either are not
providing correct info or are not correctly following the
requirements.

axel


Dear Axel ,

Thanks for you reply .
Your ideas are always so helpful , Thanks a lot .
When I use -p 1 1 1 1 instead of -p 4x1 it works .

When I don’t use " variable world " and " temper" command , I mean when I use this : mpirun -np 4 lmp_mpi -p 4x1 -in in.input
for a simple NVT simulation , it works but when I change it to "variable world " & “temper” it doesn’t !

Best ,
Saeed.