Installing GULP

Hi, I am using gfortran 9.4 but am getting this error when performing the command ./mkgulp

cd …/…/Utils/pGFNFF/Src/; make FC=‘gfortran -framework accelerate -fallow-argument-mismatch ’ FCFLAGS=’-O3 -ffpe-summary=invalid,zero,overflow -I… ’
make[1]: Entering directory ‘/home/mollyb/gulp-6.1/Utils/pGFNFF/Src’
gfortran -framework accelerate -fallow-argument-mismatch -O3 -ffpe-summary=invalid,zero,overflow -I… -c m_pgfnff_types.F90
gfortran: error: accelerate: No such file or directory
gfortran: error: unrecognized command line option ‘-framework’
gfortran: error: unrecognized command line option ‘-fallow-argument-mismatch’; did you mean ‘-Wno-argument-mismatch’?
make[1]: *** [Makefile:111: m_pgfnff_types.o] Error 1
make[1]: Leaving directory ‘/home/mollyb/gulp-6.1/Utils/pGFNFF/Src’
make: *** [makefile:276: …/…/Utils/pGFNFF/Src//libpGFNFF.a] Error 2
mv: cannot stat ‘gulp’: No such file or directory

Hi Molly,
Apologies for the “-framework accelerate” option - this is for Mac computers to enable the fast maths libraries, but won’t work on Linux. I’ve switched the default so that this isn’t present. You can edit mkgulp and edit the line with this option to remove it (or uncomment the line just above without it and comment the line with it).
The “-fallow-argument-mismatch” is covered in the README file. This means you have an old version of gfortran (before v10) where this option didn’t exist. You can fix by either updating your compiler or remove/comment as above.
Regards,
Julian

Hi Julian,
I hope you are doing well. I’m trying to install Gulp but keep facing these issues:

  1. I am getting almost the same error as Molly got when performing the command ./mkgulp
    [cd …/…/Utils/pGFNFF/Src/; make FC=‘gfortran -fallow-argument-mismatch ’ FCFLAGS=’-O3 -ffpe-summary=invalid,zero,overflow -I… ’
    make[1]: Entering directory ‘/mnt/c/Users/Samaneh/gulp-6.1/Utils/pGFNFF/Src’
    gfortran -fallow-argument-mismatch -O3 -ffpe-summary=invalid,zero,overflow -I… -c m_pgfnff_types.F90
    gfortran: error: unrecognized command line option ‘-fallow-argument-mismatch’; did you mean ‘-Wno-argument-mismatch’?
    make[1]: *** [Makefile:111: m_pgfnff_types.o] Error 1
    make[1]: Leaving directory ‘/mnt/c/Users/Samaneh/gulp-6.1/Utils/pGFNFF/Src’
    make: *** [makefile:274: …/…/Utils/pGFNFF/Src//libpGFNFF.a] Error 2
    mv: cannot stat ‘gulp’: No such file or directory].
  2. I followed your advice regarding these errors and edited mkgulp but now I keep getting ongoing syntax errors such as " unexpected ‘;;’". Any advice is highly appreciated.
    Regards,

Hi Sama,

I’m afraid I’m not sure what’s going on - all I can guess is that when you deleted the -fallow-argument-mismatch option then you must have deleted too much from the line (e.g. delete to the end of the line) and corrupted the mkgulp file. I’ll try to attach a version of mkgulp where I’ve just removed this option to see if it helps you. Of course the other option is to updated your gfortran compiler to at least version 10, if not version 11, as this option will then be present and required.
Regards,

Julian
mkgulp_old_gfortran (11.4 KB)

Hi again,

Thanks a lot for your quick reply and great support. I’ll try it to see how it goes. Thanks again.

Regards,

Hi again,

I gave it a try on both my laptop and cluster but got this error:
gfortran: error: csignal.o: No such file or directory
make: *** [makefile:221: gulp] Error 1
mv: cannot stat ‘gulp’: No such file or directory
Any advice is highly appreciated.

Regards,

Hi Sama,
Sorry for the hiccup - RUNCC was missing from the gfortran serial setup. I’ll attach a version with the extra line (or you can type “gfortran -c csignal.c” and move the csignal.o to the sub-directory with all the other .o files). I’ve also added the mkgulp_old_gfortran file to the tarfile for 6.1 so that users can just copy a file rather than edit a line in mkgulp.
Regards,
Julian

mkgulp_old_gfortran (11.4 KB)

1 Like

Hi Julian,

I tried to install gulp using this version of mkgulp_old_gfortran (renamed to mkgulp) and I’m getting errors about “undefined reference”. With the final line of error being: “collect2: error: ld returned 1 exit status
make: *** [makefile:222: gulp] Error 1
mv: cannot stat ‘gulp’: No such file or directory”

Hi Molly,
The key thing is to look and see what is “undefined” in the error messages. My guess would be the maths libraries which can be set by commenting/uncommenting the MLIB lines in the mkgulp file depending on whether you have installed optimised maths libraries or not. In the latest tar file for 6.1 I’ve set the default to be source compiled lapack/blas so that things will work for those who are not comfortable with editing the mkgulp file, though the use of optimised maths libraries is recommend if available. I’ll attach more versions of mkgulp with the change here.
Regards,
Julian
mkgulp (11.5 KB)
mkgulp_old_gfortran (11.4 KB)

Hi Julian,
Thanks for that, the new file worked.
I’ve now got an issue with setting the environmental variables. I’ve added the environment variables into the .bashrc file in addition to the .profile file, and I am able to run GULP optimisations within the wsl terminal successfully. However, these environments don’t seem to follow across to jupyter notebook (even when launched from the same shell) as I am getting an error which indicates that I am unable to generate a gulp_opt.xyz file. the gulp_opt.ginout file which is generated is blank.
I also have tried defining the environments within the workbook but am getting the same error.

Best wishes,
Molly

Hi Molly,
I think you may need to post this one to a forum for jupyter notebooks since it seems to be an issue with how these work rather than GULP if it runs fine outside of the notebook. GULP shouldn’t need the environment variables set to work if you place everything you need in the local directory.
Best regards,
Julian