Problems Signing In

Here are some issues people have encountered when trying to sign in the main Materials Project website, and their solutions:

  1. I want to log in with my social identity provider (Google/Facebook/Yahoo), but I can’t.

    Ensure that your password for your provider is correct (go to their site and log in there), ensure that you have a full name set on that account, and ensure that you allow Materials Project to see your basic profile info (name and email address).

    You also may be behind a firewall that doesn’t allow Google/Facebook/Yahoo. In that case, use our email-based option as a fallback.

  2. I appear to sign in OK (the popup goes away), but then I remain on the sign-in screen.

    It may take a few seconds, depending on your connection, to actually get logged in. This is because we have an external identity provider verify your email address so that we don’t have to store any passwords on our servers.

    You may also have an older browser that won’t work well with our website at all. The latest version of Mozilla Firefox, Google Chrome, or Microsoft Edge will work well. Old versions of Internet Explorer do not work well at all.

  3. I tried using the email option several times but haven’t received a login link.

    We currently don’t do any “deep” validation of email addresses, so if it “looks right”, i.e. you mistype [email protected] as, we will still try to send to the wrong address. We plan on implementing such protection soon, but in the meantime, double-check what you type in before submitting.

    Also, there is a known issue with Tencent addresses, where Tencent throttles delivery and you might not get an email within a reasonable amount of time. Please consider using an alternative to your address for login.

Still having issues? Reply to this topic with what you tried.

getting an odd message when logging in.


then it goes nowhere…

an ideas?

Hi Michael,

It looks like you were able to log in and register successfully three minutes after this post using our Mozilla Persona option, which we just replaced with a purely email-based equivalent where you get a one-time login link and don’t ever need a password. Hopefully this will be a robust option for you and others. We delegate the social login stuff to a third party, so it’s hard for us to debug.

I tried using the email option several times but haven’t received a login link.

1 Like

Sorry for your trouble. I notice you used a email address to sign up for this forum, so it seems the Google login option should be available to you, but I understand if you wish to use e.g. an institutional email account for login. I don’t see any mail delivery failures for said account, so I presume you tried the email option with another email address.

Reviewing the email logs, it appears that several email addresses people are entering are non-obviously invalid, i.e. they “look fine”, but e.g. are mistyped so that they do not correspond to anyone’s actual email address. There are tools available to more comprehensively validate email addresses, and we will implement one shortly so as to mitigate that particular issue.

Hi, I tried several times to login by email but I still did not receive anything from you. could you please help to resolve this problem? I used different email address to log in and every time it always redirected to a page showed “”. Thanks a lot!!!

There was a bug related to a regular expression in a third-party library. We have patched this. You should be good to go now. Thanks for reporting.

Can someone please increase the accepted length of the email addresses at the login of the materials project?

I do not know why it got restricted, I am just not able to put in all of my 36 characters!

Hi C.S.,

Sorry about that. Our email input should now accept email addresses up to the IETF-sanctioned maximum of 254 characters. Please try again.

Explanation, if of interest: It looks like the third-party library we adopted for the passwordless email login was adapted from code originally written to accept 30-character-max username input (the popular Django web framework restricts usernames to 30 characters).


Dear Material Project team,

I am currently not able to login to the materials project webpage. I have to use the login by email-address but after entering my email, the webpage is stucked with the spinning wheel. No difference when using firefox or IE.

Any help is very welcome.


I have been unable to register as well, using the email option. I get the following error message

Error occurred, unable to validate address.

I have tried re-typing the address to make sure I didn’t enter it incorrectly, but no luck. Any help would be appreciated. Thanks.

@sjlimmer, that specific error is shown when the service we contact to spot-check an email address either has an internal error or simply doesn’t respond after 30 seconds. Sorry for the inconvenience. I just tried it using my email address with success, and I tried it again using the email address you used to register with this forum, and that seemed to work, so it appears the service was down temporarily.

Yeah, I just got a login link moments before your response. Thanks for looking into this for me.

Dear Materialsproject staff, I receive an error upon trying to login with my email address. It reads: Email address failed back-end validation: (1406, “Data too long for column ‘code’ at row 1”).
So I cannot use the database. With best greetings from Sweden. D. Arvanitis, Uppsala University, Sweden ([email protected]).


Hi there, I’m encountering the same issue as Dimitri. I tried different e-mail addresses, but it made no difference. Any help would be very much appreciated! Thanks in advance.


Like s.e. and Dimitri, I’m having the same problem. Thanks for any assistance you can provide!

1 Like

@crl @s.e @dimitriarv thank you for reporting this issue. I’m looking into it now.

I think this is fixed now. It was a bug in the newest version of the library MP uses for email-based login. I will report this to the library maintainers. Thank you for using the Materials Project.


Hi Donny,

I tried again today. This time, I receive an email, but the link appears to be invalid. I receive the following error:

" Please enter the login code that was sent to you.

Login code:

  • Login code is invalid. It might have expired."


1 Like

Dear Materials project staff,
I have tried a few times to login with my email address ([email protected]) without success. The home page gives the message that a login email is sent but no email is received. The email login option did work in the past with the same address. I did check the junk box just in case nothing also there. It would help a lot to address this issue, I find the materials project database very useful, and a very positive initiative!
With best greetings from Sweden
Dimitri Arvanitis, Uppsala University

1 Like